navigation screen wont turn on :( - AcuraZine Community
AcuraZine Acura Forums Home Acura CL Forums Acura ILX Forums Acura MDX Forums Acura NSX Forums Acura RDX ForumsAcura RL ForumsAcura RSX ForumsAcura TL ForumsAcura TSX ForumsAcuraZine ZDX DiscussionAcuraZine Regional DiscussionAcuraZine Off Topic Discussion

Go Back   AcuraZine Community > AcuraZine TL Community > Third Generation TL (2004-2008) > Problems & Fixes
Sign in using an external account
Register Forgot Password?
Register Albums FAQ Members Calendar Search Today's Posts Mark All Read ExperienceUsed CarsVendorsGarage
Search
Welcome to AcuraZine Community

Notices

Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread
Old 08-23-2009, 10:20 AM   #1
dpace32
Registered Member
Garage is empty, add now
 
dpace32's Avatar
 
Trader Rating: (0)
Join Date: Jun 2008
Posts: 37
Thanks: 3
Thanked 0 Times in 0 Posts
Points: 4,842, Level: 44
Points: 4,842, Level: 44 Points: 4,842, Level: 44 Points: 4,842, Level: 44
Activity: 0.3%
Activity: 0.3% Activity: 0.3% Activity: 0.3%
navigation screen wont turn on :(

Hello -

I have an 05 Acura TL w/nav. Unfortuantely this morning I went to go start my car and the navi screen wouldn't turn on. I dont see the OK screen or anything. It looks like it flashes for a second and then it goes off instantly. I can hear the radio, change the channels using the buttons below the screen but nothing on the screen actually works. Does anyone have any suggestions on what I can check to see if I can fix this myself?

Thank you!
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Acurazine!
dpace32 is offline   Reply With Quote
Old 08-23-2009, 11:25 AM   #2
BradE
Registered Member
Garage is empty, add now
 
Trader Rating: (0)
Join Date: Aug 2008
Age: 31
Posts: 792
Thanks: 0
Thanked 3 Times in 1 Post
Points: 4,809, Level: 44
Points: 4,809, Level: 44 Points: 4,809, Level: 44 Points: 4,809, Level: 44
Activity: 3.2%
Activity: 3.2% Activity: 3.2% Activity: 3.2%
Take the disc out of the drive (located in trunk) and make sure it's not scratched or damaged. Blow out any dust or debris in the drive as well. Re-insert the disc, then retry.

I'm amazed how many probablems, and Navi failues, I've been reading about with the 04-06's TL's as of late. Not a good sign, especially on a part that expensive.
__________________
2008 TL Type S
Alabaster Silver / Ebony
Stock, no mods!

Pessimists are well informed optimists.
BradE is offline   Reply With Quote
Old 08-23-2009, 11:45 AM   #3
dwb993
Registered Member
2006 Acura TL
 
dwb993's Avatar
 
Trader Rating: (13)
Join Date: Sep 2005
Location: Shrewsbury, PA
Age: 49
Posts: 2,727
Thanks: 155
Thanked 128 Times in 107 Posts
Points: 11,436, Level: 70
Points: 11,436, Level: 70 Points: 11,436, Level: 70 Points: 11,436, Level: 70
Activity: 0.3%
Activity: 0.3% Activity: 0.3% Activity: 0.3%
what happens if you press the Map/Guide button, or any other button for that matter? Also, is your Navi hacked with the OK Button mod? On my 06, before I applied the hack, if I did not press OK the screen would go black. It would come back on when I pressed a button, but I would then have to press the OK button to get to anything useful.
__________________
I copied Aaron.
Domed Decals for your 3G TL bumper!!!

SSFD
dwb993 is offline   Reply With Quote
Old 08-23-2009, 11:46 AM   #4
dpace32
Registered Member
Garage is empty, add now
 
dpace32's Avatar
 
Trader Rating: (0)
Join Date: Jun 2008
Posts: 37
Thanks: 3
Thanked 0 Times in 0 Posts
Threadstarter
Points: 4,842, Level: 44
Points: 4,842, Level: 44 Points: 4,842, Level: 44 Points: 4,842, Level: 44
Activity: 0.3%
Activity: 0.3% Activity: 0.3% Activity: 0.3%
Quote:
Originally Posted by dwb993 View Post
what happens if you press the Map/Guide button, or any other button for that matter? Also, is your Navi hacked with the OK Button mod? On my 06, before I applied the hack, if I did not press OK the screen would go black. It would come back on when I pressed a button, but I would then have to press the OK button to get to anything useful.
If I press the map button nothing happens. Also I don't even get to see the OK button, it never shows up since the screen doesnt fully turn on.
dpace32 is offline   Reply With Quote
Old 08-23-2009, 12:54 PM   #5
dpace32
Registered Member
Garage is empty, add now
 
dpace32's Avatar
 
Trader Rating: (0)
Join Date: Jun 2008
Posts: 37
Thanks: 3
Thanked 0 Times in 0 Posts
Threadstarter
Points: 4,842, Level: 44
Points: 4,842, Level: 44 Points: 4,842, Level: 44 Points: 4,842, Level: 44
Activity: 0.3%
Activity: 0.3% Activity: 0.3% Activity: 0.3%
Smile

Quote:
Originally Posted by BradE View Post
Take the disc out of the drive (located in trunk) and make sure it's not scratched or damaged. Blow out any dust or debris in the drive as well. Re-insert the disc, then retry.

I'm amazed how many probablems, and Navi failues, I've been reading about with the 04-06's TL's as of late. Not a good sign, especially on a part that expensive.
GOT IT TO WORK!

I can't say I did anything magic to fix it though. I stayed away from my car for a couple hours, came back to turn it on to drive somewhere and the navi screen asked for my pin. I entered the pin from the dealer's card that was in the book and the navi configutation process began. It took about 10 minutes to go through it but after everything was done, all my saved stations/addresses, etc. came back and the system works great again

Thank you both for your quick replies!
dpace32 is offline   Reply With Quote
Old 08-23-2009, 12:54 PM
AcuraZine
Acura Integra




Paid Advertisement


 
 
 
submit to reddit
Reply

Tags
2005, 45, acura, car, mdx, minutes, nav, navigation, pin, screen, tl, tsx, turn, turns, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 8:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Acurazine.com content, comments, or advertising. Acurazine.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Acurazine.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Passwords Backup